using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"flag.*regex";
string input = @"You must use the s flag,
if you want the regex to find matches over multiple lines.";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}