$re = '/flag.*regex/s';
$str = 'You must use the s flag,
if you want the regex to find matches over multiple lines.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);