package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)flag.*regex`)
var str = `You must use the s flag,
if you want the regex to find matches over multiple lines.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}