const regex = /flag.*regex/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('flag.*regex', 's')
const str = `You must use the s flag,
if you want the regex to find matches over multiple lines.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}