re = /flag.*regex/
str = 'You must use the s flag,
if you want the regex to find matches over multiple lines.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end