#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(\w+):(.+)\]([^]]+)\[\1\]"
Local $sString = "[document:13]text[document]" & @CRLF & _
"[item:2]texttext[item]"
Local $sSubst = "<a href="example.com/$1?id=$2">$3</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)