const regex = /\[(\w+):(.+)\]([^]]+)\[\1\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\w+):(.+)\\]([^]]+)\\[\\1\\]', 'g')
const str = `[document:13]text[document]
[item:2]texttext[item]`;
const subst = `<a href="example.com/$1?id=$2">$3</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);