using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w+):(.+)\]([^]]+)\[\1\]";
string substitution = @"<a href=""example.com/$1?id=$2"">$3</a>";
string input = @"[document:13]text[document]
[item:2]texttext[item]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}