re = /\[(\w+):(.+)\]([^]]+)\[\1\]/
str = '[document:13]text[document]
[item:2]texttext[item]'
subst = '<a href="example.com/$1?id=$2">$3</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result