$re = '/\[(\w+):(.+)\]([^]]+)\[\1\]/';
$str = '[document:13]text[document]
[item:2]texttext[item]';
$subst = "<a href=\"example.com/$1?id=$2\">$3</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;