using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/lunch-box\/)[^\/]+\/?$";
string input = @"/lunch-box/xxxxxabc/ABCD123
/lunch-box/xxxxxabc/
/lunch-box/xxxxxabc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}