import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/lunch-box\\/)[^\\/]+\\/?$";
final String string = "/lunch-box/xxxxxabc/ABCD123\n"
+ "/lunch-box/xxxxxabc/\n"
+ "/lunch-box/xxxxxabc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}