re = /^(\/lunch-box\/)[^\/]+\/?$/m
str = '/lunch-box/xxxxxabc/ABCD123
/lunch-box/xxxxxabc/
/lunch-box/xxxxxabc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end