package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\/lunch-box\/)[^\/]+\/?$`)
var str = `/lunch-box/xxxxxabc/ABCD123
/lunch-box/xxxxxabc/
/lunch-box/xxxxxabc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}