use strict;
my $str = '"#report/content-pages/a526620w98080294p102751793/?explorer-table.advFilter=[[0,"analytics.pagePath","RE","\\\\?|&|#",0],[0,"analytics.pagePath","PT","search",1],[1,"analytics.pageviews","EQ","2",0]]&explorer-table.plotKeys=[]&explorer-table.rowCount=50/"';
my $regex = qr/table\.advFilter=\[(\[.+\])\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}