// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"table\.advFilter=\[(\[.+\])\]").unwrap();
let string = "\"#report/content-pages/a526620w98080294p102751793/?explorer-table.advFilter=[[0,\"analytics.pagePath\",\"RE\",\"\\\\?|&|#\",0],[0,\"analytics.pagePath\",\"PT\",\"search\",1],[1,\"analytics.pageviews\",\"EQ\",\"2\",0]]&explorer-table.plotKeys=[]&explorer-table.rowCount=50/\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}