import Foundation
let pattern = #"table\.advFilter=\[(\[.+\])\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##""#report/content-pages/a526620w98080294p102751793/?explorer-table.advFilter=[[0,"analytics.pagePath","RE","\\?|&|#",0],[0,"analytics.pagePath","PT","search",1],[1,"analytics.pageviews","EQ","2",0]]&explorer-table.plotKeys=[]&explorer-table.rowCount=50/""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}