using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"folder1\/userlist\.php(.+)";
string input = @"folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}