// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"folder1\/userlist\.php(.+)").unwrap();
let string = "folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}