import Foundation
let pattern = #"folder1\/userlist\.php(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}