re = /folder1\/userlist\.php(.+)/
str = 'folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45'
# Print the match result
str.match(re) do |match|
puts match.to_s
end