import re
regex = re.compile(r"folder1\/userlist\.php(.+)")
test_str = "folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")