#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "s/\^(ssh)$/\sshd/\g;"
Local $sString = "D ABCD12jjjjjj" & @CRLF & _
"D ABCD1" & @CRLF & _
"D ABCD123" & @CRLF & _
"D ABCD12" & @CRLF & _
"D ABCD" & @CRLF & _
"D ABCD1"
Local $sSubst = "sshd"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)