const regex = /s/\^(ssh)$/\sshd/\g;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s\/\\^(ssh)$\/\\sshd\/\\g;', 'g')
const str = `D ABCD12jjjjjj
D ABCD1
D ABCD123
D ABCD12
D ABCD
D ABCD1`;
const subst = `sshd`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);