// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"s/\^(ssh)$/\sshd/\g;").unwrap();
let string = "D ABCD12jjjjjj
D ABCD1
D ABCD123
D ABCD12
D ABCD
D ABCD1";
let substitution = "sshd";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}