$re = '/s/\^(ssh)$/\sshd/\g;/';
$str = 'D ABCD12jjjjjj
D ABCD1
D ABCD123
D ABCD12
D ABCD
D ABCD1';
$subst = "sshd";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;