use strict;
my $str = 'D ABCD12jjjjjj
D ABCD1
D ABCD123
D ABCD12
D ABCD
D ABCD1';
my $regex = qr/s/\^(ssh)$/\sshd/\g;/p;
my $subst = 'sshd';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";