#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<pre>((?>(?!</?pre).|(?R))*)</pre>"
Local $sString = "zzz<pre>sssss<pre>fff</pre>ff</pre>zzz" & @CRLF & _
"zzz<pre>sssss<pre>fff</pre>ff</pre>zzz;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<pre>sssss" & @CRLF & _
" <pre>ggg" & @CRLF & _
" <pre>fff</pre>" & @CRLF & _
" </pre>ff" & @CRLF & _
"</pre>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")