using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<pre>((?>(?!</?pre).|(?R))*)</pre>";
string input = @"zzz<pre>sssss<pre>fff</pre>ff</pre>zzz
zzz<pre>sssss<pre>fff</pre>ff</pre>zzz;
<pre>sssss
<pre>ggg
<pre>fff</pre>
</pre>ff
</pre>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}