import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<pre>((?>(?!</?pre).|(?R))*)</pre>";
final String string = "zzz<pre>sssss<pre>fff</pre>ff</pre>zzz\n"
+ "zzz<pre>sssss<pre>fff</pre>ff</pre>zzz;\n\n\n"
+ "<pre>sssss\n"
+ " <pre>ggg\n"
+ " <pre>fff</pre>\n"
+ " </pre>ff\n"
+ "</pre>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}