use strict;
my $str = 'zzz<pre>sssss<pre>fff</pre>ff</pre>zzz
zzz<pre>sssss<pre>fff</pre>ff</pre>zzz;
<pre>sssss
<pre>ggg
<pre>fff</pre>
</pre>ff
</pre>';
my $regex = qr~<pre>((?>(?!</?pre).|(?R))*)</pre>~sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}