$re = '~<pre>((?>(?!</?pre).|(?R))*)</pre>~si';
$str = 'zzz<pre>sssss<pre>fff</pre>ff</pre>zzz
zzz<pre>sssss<pre>fff</pre>ff</pre>zzz;
<pre>sssss
<pre>ggg
<pre>fff</pre>
</pre>ff
</pre>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);