#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)https?:\/\/(www\.)?([^.]*)[^\/]*\/([^?\r\n]*)"
Local $sString = "https://website-name.some-domain.some-sub-domain.com/resourceId?randomContent" & @CRLF & _
"https://website-name.some-domain.some-sub-domain.com/resourceId" & @CRLF & _
"https://www.website-name.some-domain.some-sub-domain.com/resourceId?randomContent" & @CRLF & _
"https://www.website-name.some-domain.some-sub-domain.com/resourceId"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")