package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)https?:\/\/(www\.)?([^.]*)[^\/]*\/([^?\r\n]*)`)
var str = `https://website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://website-name.some-domain.some-sub-domain.com/resourceId
https://www.website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://www.website-name.some-domain.some-sub-domain.com/resourceId`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}