const regex = new RegExp('(?i)https?:\\/\\/(www\\.)?([^.]*)[^\\/]*\\/([^?\\r\\n]*)', 'gm')
const str = `https://website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://website-name.some-domain.some-sub-domain.com/resourceId
https://www.website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://www.website-name.some-domain.some-sub-domain.com/resourceId`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}