$re = '`(?i)https?:\/\/(www\.)?([^.]*)[^\/]*\/([^?\r\n]*)`m';
$str = 'https://website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://website-name.some-domain.some-sub-domain.com/resourceId
https://www.website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://www.website-name.some-domain.some-sub-domain.com/resourceId';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);