// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)https?:\/\/(www\.)?([^.]*)[^\/]*\/([^?\r\n]*)").unwrap();
let string = "https://website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://website-name.some-domain.some-sub-domain.com/resourceId
https://www.website-name.some-domain.some-sub-domain.com/resourceId?randomContent
https://www.website-name.some-domain.some-sub-domain.com/resourceId";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}