import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\s+\\b";
final String string = "One OS to rule them all,\n"
+ " One OS to find them.\n"
+ " One OS to call them all,\n"
+ " And in salvation bind them.\n"
+ " In the bright land of Linux,\n"
+ " Where the hackers play.";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}