import re
regex = re.compile(r"\b\s+\b", flags=re.MULTILINE)
test_str = ("One OS to rule them all,\n"
" One OS to find them.\n"
" One OS to call them all,\n"
" And in salvation bind them.\n"
" In the bright land of Linux,\n"
" Where the hackers play.")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)