re = /\b\s+\b/m
str = 'One OS to rule them all,
One OS to find them.
One OS to call them all,
And in salvation bind them.
In the bright land of Linux,
Where the hackers play.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result