const regex = /\b\s+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\s+\\b', 'gm')
const str = `One OS to rule them all,
One OS to find them.
One OS to call them all,
And in salvation bind them.
In the bright land of Linux,
Where the hackers play.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);