#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}(\.\d{1,5})?$"
Local $sString = "Please help me with a regular expression in javascript which takes one or two digits before decimal point and optional or max five digits after decimal point .Possible values are 12.345" & @CRLF & _
"12.12" & @CRLF & _
"1.3" & @CRLF & _
"1.12345" & @CRLF & _
"12" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")