// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,2}(\.\d{1,5})?$").unwrap();
let string = "Please help me with a regular expression in javascript which takes one or two digits before decimal point and optional or max five digits after decimal point .Possible values are 12.345
12.12
1.3
1.12345
12
1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}