import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}(\\.\\d{1,5})?$";
final String string = "Please help me with a regular expression in javascript which takes one or two digits before decimal point and optional or max five digits after decimal point .Possible values are 12.345\n"
+ "12.12\n"
+ "1.3\n"
+ "1.12345\n"
+ "12\n"
+ "1\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}