const regex = /^\d{1,2}(\.\d{1,5})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2}(\\.\\d{1,5})?$', 'gm')
const str = `Please help me with a regular expression in javascript which takes one or two digits before decimal point and optional or max five digits after decimal point .Possible values are 12.345
12.12
1.3
1.12345
12
1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}