#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.{8,})(?=.*[A-Z]{1,})(?=.*[a-z]{1,})(?=.*[!"#%&()*+,.:/;<=>?@[_`{|}~\]\'\$\-\^\\]{1,})(?=.*[0-9]{1,})"
Local $sString = "Pas$w0rd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")