using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8,})(?=.*[A-Z]{1,})(?=.*[a-z]{1,})(?=.*[!""#%&()*+,.:/;<=>?@[_`{|}~\]\'\$\-\^\\]{1,})(?=.*[0-9]{1,})";
string input = @"Pas$w0rd";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}