use strict;
my $str = 'Pas$w0rd';
my $regex = qr/^(?=.{8,})(?=.*[A-Z]{1,})(?=.*[a-z]{1,})(?=.*[!"#%&()*+,.:/;<=>?@[_`{|}~\]\'\$\-\^\\]{1,})(?=.*[0-9]{1,})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}