import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8,})(?=.*[A-Z]{1,})(?=.*[a-z]{1,})(?=.*[!\"#%&()*+,.:/;<=>?@[_`\\{|\\}~\\]\\'\\$\\-\\^\\\\]{1,})(?=.*[0-9]{1,})";
final String string = "Pas$w0rd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}