$re = '/^(?=.{8,})(?=.*[A-Z]{1,})(?=.*[a-z]{1,})(?=.*[!"#%&()*+,.:/;<=>?@[_`{|}~\]\'\$\-\^\\\\]{1,})(?=.*[0-9]{1,})/';
$str = 'Pas$w0rd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);